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Getting Started 
Topics Covered 

• Welcome 
• Running the Application 
• Application Overview 
• File Formats 

 
This section will familiarize you with the purpose of the application and its main components.  
 
 
Welcome 
 
What is C.L.I.P.? 
Chemistry Learning in Progress is a Java-built application that allows a user to:  

1. Create Tile Arrangements 
2. Save Incomplete and Completed Tile Arrangements 
3. Open Tile Arrangements for Playback Viewing or Continue Working on Incomplete Tile 

Arrangements 
4. Print Tile Arrangements and Additional Information 
5. Build new Tile Sets 

 

Who is the Team?   
The development team consisted of Nathan Mikeska, Neil Alfredson, Richard Carney, and Brian 
Navarro.   
 
 
Running the Application 
 
Requirements 
The requirements needed to run the application include: 

1. A Java supported operating system (i.e. Microsoft Windows, Mac OS, or Linux) 
2. Java Runtime Environment 1.4.2 or later.  If you do not have Java Runtime Environment 

1.4.2 or later, it is available to download for free from http://www.java.com.  
 
Starting the Application 
Double click on the file CLIP.jar and after a few moments the application will load.    
 
 
Application Overview 
 
File Menu  
In this menu, a user can: 

1. Open a Tile Set, Open a Tile Arrangement for Playback, or Continue a Tile Arrangement  
2. Save a Tile Arrangement as Incomplete or Completed 
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3. Print the Tile Arrangement, Print Additional Information about the Tile Arrangement, or 
Print the Tile Arrangement to a file  

4. Exit the application 
 
Tools Menu  
In this menu, a user can:  

1. Add a Blank Tile to a Tile Arrangement 
2. Create a new Tile Set 
3. Modify an existing Tile Set 

 
View Menu  
In this menu, a user can: 

1. Position the Tile Bin on the right or left side of the application 
2. Turn on/off the Minimap  
3. Turn on/off the lines of the Grid  

 
Help Menu  
In this menu, a user can: 

1. View the instructions for a Tile Set that is in use 
2. View the application version of the User Manual 
3. View information about the team and the application 

 
The Grid        The Tile Bin 
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The Minimap 

 
 
The Playback Controls 

 
 
 
File Formats 
 
Set 
A file with the extension .set represents a Tile Set that can be opened up and arranged on the 
Grid.  They are created using the Create Tile Set feature of the application. 
 

Log 
A file with the extension .log represents a Tile Arrangement, which is a sorted arrangement of 
tiles for a specific Tile Set.  They are created after a user saves their Tile Arrangement either to 
be viewed in playback or to be continued later.   
 
  

Creating a Tile Arrangement 
Topics Covered 

• Tile Set 
• Arranging Tiles 
• Saving a Tile Arrangement 
• Opening an Incomplete Tile Arrangement 

 
This section will familiarize you with the basics of arranging the tiles of a set to create a Tile 
Arrangement.   
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Tile Set 
 
Opening a Tile Set 
In the File Menu, select Open and then choose Tile Set.  This will bring up an Open Tile Set 
dialog box which will provide you with three ways to open a Tile Set.   

1. Select a Tile Set from the included sets list and click ok 
2. Double click on a Tile Set from the included sets list 
3. Find a Tile Set on your local hard drive by clicking the browse button.  

 
Tile Set Instructions 
These are specific instructions that relate to a Tile Set which appear in a message box after a set 
has been opened.      
 
 
Arranging the Tiles 
The process of arranging tiles is done by using the application’s drag and drop feature to move 
tiles from the Tile Bin to the Grid.  The objective is to arrange or group the tiles of a set using the 
characteristics identified on each tile.  The overall group created from arranging the tiles on the 
Grid is called a Tile Arrangement.      
 
The Tile Bin 
Once a Tile Set is loaded, all the tiles belonging to the set are placed here.  Below are some 
options available to customize your use of the Tile Bin.   
 
Resizing 
Use the arrows at the top left of the Tile Bin to adjust how many tiles you see at once.   In 
addition, the bar that holds the arrow buttons is draggable, allowing you to adjust how many tiles 
you see, as well.  By default, only one column width of tiles is visible after a Tile Set is loaded.     
 
Changing the Position 
To change the side the Tile Bin is on, select from the View menu the option Tile Bin Position, 
and then choose either To the Left or To the Right. 
 
The Grid 
The tiles that are loaded in the Tile Bin should be dragged to the Grid and arranged into an 
overall group that represents the final arrangement.  Keep in mind that you may expand the Tile 
Bin using the Resize feature and start grouping tiles there, but the final arrangement of a set has 
to be done on the Grid in order to count.            
 
Adding Blank Tiles 
If the Tile Set allows, you can fill in gaps in your Tile Arrangement with blank tiles.  To add a 
blank tile, select in the Tools menu the Add Blank Tile option and this will bring up a Blank Tile 
information dialog.  Keep in mind that there may be restrictions on how many blank tiles you can 
add and some information may be required before adding the blank tile.  This is denoted by the 
red coloring of the caption next to the required information.     
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Context Menu 
The context menu is a shortcut method for accessing some main menu options.  This menu is 
accessible by clicking the mouse in the Grid or the Tile Bin.  The options available in this 
shortcut method include: 

1. Adding Blank Tiles  
2. Editing Blank Tiles 
3. Access to help options (Tile Set instructions and in-application user manual) 
4. Changing the position of the Tile Bin 
5. Turning on/off the Minimap  
6. Turning on/off the lines of the Grid 

 
Accessing the context menu: 
In Windows or Linux, click the right mouse button. 
In Mac, hold down the control key while clicking the mouse. 
 
Minimap 
This is a miniature version of the Grid that allows the user to view the placement of all their tiles 
and move quickly around the Grid.   
 
Fast Scrolling 
You can quickly move to any area on the Grid by holding down a mouse button while dragging 
the mouse across the Grid.   
 
 
Saving a Tile Arrangement 
There are two options for saving a Tile Arrangement, which are located in the File menu under 
Save.    
 

Incomplete Arrangement 
If you wish to pause and return to finish your arrangement later, choose under Save the option 
Incomplete Tile Arrangement. 
 
Completed Arrangement 
If you wish to finalize your arrangement and save it, choose under Save the option Completed 
Tile Arrangement.  After you select this option, you will be presented with a confirmation box.  
Then, depending on the Tile Set, you may have to provide some additional information such as: 

1. Reasons for each tile that you left in the Tile Bin   
2. Comments on your overall arrangement.  

 
 
Opening an Incomplete Tile Arrangement 
If you wish to continue working on an existing Tile Arrangement, you may select in the File 
Menu, the option Open and then choose Continue Tile Arrangement.  
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Playback 
Topics Covered 

• Viewing a Tile Arrangement 
• Using the Controls 
• Information Display 
• Viewing Comments 

 
This section will familiarize you with using the playback feature of the application. 
 
 
Viewing a Tile Arrangement 
To use the playback feature, select from the File Menu the option Open and choose Tile 
Arrangement.  Then in the file dialog box that appears, find the Tile Arrangement you wish to 
play back.  The playback will show you all the moves made to create that arrangement.  The 
types of moves shown include: 

1. Dragging and dropping tiles to and from the Tile Bin and Grid 
2. Adding/editing/removing blank tiles 
3. Any comments added to the arrangement after saving a completed arrangement. 

 
 
Using the Controls 
Below is a list of controls that manipulate the viewing of a Tile Arrangement during playback.   

 
 
Start Button 
This button will put the playback into motion at normal speed, which is two tile moves per 
second.   

 
Stop Button 
This button will stop your playback at its current location.   

 
Slider Bar 
This control displays the current position in playback and may be used, if dragged forward or 
backward, to move to any other position in playback.  

 
Back Button 
This button will stop the playback at its current position and then move the playback position 
back one move.   
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Skip To Beginning Button 
This button will move the playback to the beginning.   

 
Forward Button 
This button will stop the playback at its current position and then move the playback position 
forward one move.   

 
Skip To End Button  
This button will move the playback to the end.  

 
Playback Speed Control 
This control will adjust the viewing speed of the playback. There are seven different speeds. The 
default is called normal and that shows two tile moves per second.  
 

1. 1/8 x = 1/8th the normal speed 
2. 1/4x = 1/4th  the normal speed 
3. 1/2x = 1/2 the normal speed 
4. Normal 
5. 2x = 2 times the normal speed 
6. 4x = 4 times the normal speed 
7. 8x = 8 times the normal speed 

 
 
Information Display 
Below is the information that is displayed during the playback of a Tile Arrangement.  
 
Previous Move Time 
This shows how much time passed between the current move and the previous move.  
 
Time Elapsed  
This shows how much time has passed since the beginning of the playback.   
 

Move Number 
This shows the current position in playback. 
 

Move Description 
This describes what is happening in the current move on the screen. 
 
 
Viewing Comments 
After the playback has reached the end, there may be additional information that was not 
displayed in move description area. This information can be viewed by clicking on the 
Comments button.  Below is an explanation of this information. 
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Overall Arrangement Comments 
These are comments made about the groupings used to create the Tile Arrangement. 
 
Selected Tile Comments 
These are comments made by the user to explain either a left out tile or an added blank tile.   
 
 

Creating and Modifying a Tile Set 
Topics Covered 

• Tile Set 
• Basic Options Tab 
• Advanced Options Tab 
• Tiles Tab 
 

This section will familiarize you with the options available for creating and modifying a Tile Set. 
 
 
Tile Set 
 
New 
You can create a new Tile Set by selecting in the Tools menu the option Create Tile Set.  After 
you select this option, a dialog will appear with three tabs that represent the different options for 
a Tile Set.    
 
Existing 
You may modify an existing Tile Set by selecting in the Tools menu the option Modify Tile Set.  
After you select this option, a file dialog will appear so that you may locate the Tile Set you wish 
to modify.  After you click open, a new dialog will appear with three tabs that represent the 
different options for a Tile Set.     
 
 
Basic Options Tab 
 
Name 
This is the identifier of the set.  
 
Instructions 
These are the instructions that appear in a message box when the set is loaded.   
 
Tile Size  
This is the width and height of the image files that will be used as the tiles for the set.  The 
values used by the application for both width and height are in pixels.  Furthermore, the 
measurements must be divisible by 20 and no width or height is allowed below 40.  An example 
of this is an image with a width of 100 pixels and a height of 100 pixels.   
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Grid Size 
The number of tiles that can fit side by side from left to right and from top to bottom on the Grid.  
 
 
Advanced Options Tab 
 
Allow Blank Tiles 
This determines if the Tile Set allows the user to add blank tiles to their arrangement.  
 
Feedback Types 
For blank tiles added, you may indicate what feedback you want from the user. The types of 
feedback include a name and a description.   
 
Number of Tiles 
Indicates if the Tile Set limits how many blank tiles can be added. 
 
Allow Unused Tiles 
This determines if the Tile Set allows the user to leave out any tile from their arrangement in the 
Tile Bin. 
 
Feedback Type 
For any tile left out, you may indicate if you require a reason for the tile being left out. 
 
Number of Tiles  
Indicates if the Tile Set limits how many tiles can be left out in the Tile Bin. 
 
Arrangement Options 
These are miscellaneous options for customizing the use of a Tile Set.  
 
Require Overall Comments 
Indicates if the Tile Set requires comments from the user on their overall Tile Arrangement 
 
Print 
Indicates if the user can print their Tile Arrangement and comments 
 
Randomly Remove Tiles 
Indicates if a certain number of tiles will be randomly removed from the Tile Set when it is used 
 
 
Tiles Tab 
 
Tile Listing 
A listing of all the tiles that are currently a part of the set. 
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Add Tile Button  
Adds image files to the tile listing by using a file dialog 
  
Remove Tile Button 
Removes all the selected tiles from the listing. 
 
View Tile Button 
Displays the image that represents the selected tile 

 
Set As Blank Button 
Sets the selected tile to represent the blank tile that a user will add to their arrangement.    
Howeverr, this will be grayed out if the allow blank tiles option is not used.  

 
Blank Tile Selection 
Displays the currently selected blank tile.  Also, it is an alternate method to select the blank tile.  
However, this will be grayed out if the allow blank tiles option is not used.  
 
Using Blank Tiles 
There are some important things to remember when having blank tiles in a Tile Set.   

1. For the image that is used to represent the blank tile, remember to provide sufficient 
space for the addition of a name to the blank tile for when the user is using it.  These 
names are drawn on during the addition of a blank tile, so there may instances where the 
text that is drawn on it will overlap with a blank tile’s image.   

2. You may wish to add text onto the image that represents the blank tile so that the user 
knows that double clicking on a blank tile will allow them to view its information.  

 
 

Preloaded Sets 
 
 
This section will familiarize you with how to add and remove Tile Sets from the application. 
 
Included Tile Sets 
These are Tile Sets that are packaged with the application when it is distributed.   
They are available for use from the list box that appears in the Open Tile Set dialog. 
 
Adding/Removing a Tile Set 
There are two methods for adding and removing Tile Sets: manually or automatically.   
 
Manually 
You may add and remove Tile Sets by hand if you are able to open zip files.  To make changes, 
follow these steps. 

1. Make sure that the CLIP.jar you wish to modify is not currently running. 
2. Rename the CLIP.jar to CLIP.zip 
3. Use your favorite zip application to open up CLIP.zip  
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4. Find the folder labeled preloaded sets and open it.   
5. Make your modifications  
6. Close the zip application and then rename CLIP.zip to CLIP.jar 
7. Run the application. 

 
Automatically 
You may add and remove Tile Sets using a small application that is included with the main 
application.  It is called the CLIP-Loader. To make changes, follow these steps. 

1. Make sure that the CLIP.jar you wish to modify is not currently running. 
2. Double click on the file CLIP-Loader.jar. 
3. In the file dialog that appears, locate the CLIP.jar you wish to modify and click open.  
4. To add a Tile Set, click the Add Set button.  Else, to remove a Tile Set, select a set from 

the list and click the Remove Set button. 
5. After you are satisfied with your modifications, click the Save & Exit button. 

 
 

Glossary 
 
Arranging – Also known as sorting or grouping.   
 
Blank Tiles – Customizable tiles that take descriptions about what characteristics the missing 
tiles, had they been there, would possess.  In addition to having a description, a name field is 
provided in order to help the user keep track of all the blank tiles that have been added.   
 
Completed Tile Arrangement – An arrangement of tiles that the user considers the best 
grouping of that set.  This is also known as the final arrangement. 
 
Grid – The large area of the application where tiles are dragged to and arranged in order to 
create an arrangement. The area is identifiable by the crisscrossing horizontal and vertical lines 
that are drawn there. 
 
Included Sets – These Tile Sets come with the application.  They are accessible in the list box 
that appears after selecting Open Tile Set from the File menu. 
 
Incomplete Tile Arrangement – An arrangement of tiles that the user wishes to come back 
to at a later time and continue.   
 
Left Out Tile – Also known as an Unused Tile.  This is a tile that the user has left in the Tile 
Bin after saving in order to indicate that it is not a part of their arrangement. 
 
Playback – This is the process of viewing the recorded moves that were made to create an 
arrangement.  The arrangement can be complete or incomplete since both types use the same file 
extension of .log. 
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Tile Arrangement – Also known as an arrangement.  This is any grouping of tiles made from 
a Tile Set. 
 
Tile Bin – The area of the application where tiles are loaded to when a Tile Set is opened for 
creating a Tile Arrangement.   
 
Tile Set – Also known as a set.  This is an unsorted listing of Tiles and is built using the Create 
Tile Set feature. Once created it, it can be opened for use to create an arrangement.   
 
Tile – An image file that is added to a set of images to create a Tile Set. 
 
 
Version # Date Author Description 
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